Creating a “travel” router

When I travel, and it seems like that happens WAY to much, I like to carry a MikroTik Router with me.   I use this router to simplify many of the problems I encounter with various “free” wifi spots in hotels. I might not exactly be making money, like this Traxplorio | Make Money Traveling blog professes to be possible, but I certainly am not losing any on internet connection.   In this article, I will describe how my “travel” router is configured.

First, I’ll explain some of the options and types of hardware you can use to build a router suitable for travel.  In most hotels, you will have available 2.4GHz wifi access.  The access speeds will, of course, vary in different hotels, but there are a couple of things you can do to improve the chances of getting a good strong signal as well as increase the odds of having at least usable access in the worst of hotels.  At a minimum, you will need a router with 2 wireless cards.  One of these will be configured as a client device that will connect to the strongest “visible” access point.  The second card will be configured for your use as an AP inside your hotel room.  I use a RouterBoard 433 for my travel router (you can find one HERE).  I use 2 of the R52 radio cards (available HERE).  Add an indoor case, the right pigtails and you’re all but done.  For me, I like the option of using a larger directional antenna (small 13dBi antenna is what I carry) in case the hotel I pick has really bad RF coverage (or if the hotel across the street has better internet access).  Because of this, my “client” radio has an N-Female bulkhead pigtail.  I keep an adapter handy to convert that to SMA, so that I can connect my smaller range extender antenna if that is enough antenna.

By way of an overview, I will configure ONE of the radio cards to be a client and connect to ANY available AP.  The configuration is VERY simple.  Here it is:

/interface wireless connect-list
add interface=wlan1 ssid="ButchHotel" connect=no
add interface=wlan1 connect=yes

/interface wireless
set wlan1  mode=station ssid="" band=2.4ghz-b/g disabled=no

The configuration in the connect list tells the interface wlan1 that it cannot connect to any SSID called “ButchHotel”, but any other SSID is allowable.  This is necessary if your AP (in my case, I named my SSID as “ButchHotel”) is running in the 2.4GHz band.  I usually do not have to set this up in my own router, as my AP radio is configured for 5GHz operation, since I have a 5GHz capable radio card in my laptop.  It is still a good idea to set this, but not absolutely necessary if the cards run in different bands.  It is important to note that the wireless card is configured with a “blank” SSID in station mode.  Those 2 bits of configuration force the client card to look at the connect list to see if there are “further instructions” for where to connect.  In the absense of any rules in the connect list, the radio will simply connect to any ssid it can see.

That takes care of one part of the configuration.  The wireless card will now connect to any AP it finds, but we need to get an IP address from that network.  It is VERY common for hotel networks (and frankly many other networks) to provide IP addresses via DHCP.  To turn on a DHCP client, we simply need to do the following:

/ip dhcp-client
add interface=wlan1 add-default-route=yes disabled=no use-peer-dns=yes


It is VERY IMPORTANT for many hotel networks that we set the option “use-peer-dns” to yes.  Most of these networks operate using some sort of hotspot gateway.  Very often, you will need to use their DNS servers in order to get logged into the hotspot.  It is just easier to set this and be done with fooling with DNS issues, so that is what I do.  Next, we need to set up the AP side.  I won’t go into a lot of detail here, but here are the things I configure for that:

/interface wireless security-profiles
add name=secure authentication-types=wpa-psk group-ciphers=tkip mode=dynamic-keys \
unicast-ciphers=tkip wpa-pre-shared-key=samplewpakey
/interface wireless
set wlan2 mode=ap-bridge ssid=ButchHotel band=5ghz disabled=no profile=secure
/ip address
add interface=wlan2 address=10.101.101.1/24
/ip pool
add name=dhcp_pool ranges=10.101.101.2-10.101.101.254
/ip dhcp-server network
add address=10.101.101.0/24 gateway=10.101.101.1 dns-server=10.101.101.1
/ip dhcp-server
add address-pool=dhcp_pool authoritative=yes disabled=no interface=wlan2
/ip dns set allow-remote-requests=yes

This configuration simply creates a security profile and configures the access point (remember I have a 5GHz radio card in my laptop).  Then it sets up an address, dhcp server.  Note that the DHCP server is configured to tell my PC to use the Mikrotik as it’s DNS server.  Because of that, I have to configure the DNS server on the Mikrotik to allow this.  That is what the last line above does.

In my router, I have vpn tunnels configured to connect my travel network back to my home office and my server network as well.  These are beyond the scope of this document, but I mention this to give you some ideas about the possibilities for using these “mobile” routers.  You can, additionally, use a router that has USB capability if you own a cellular modem card.  Mikrotik works very well with these cards.

So, there you have it.  I believe I have covered all the basics needed to create a travel companion that will be very useful for the “geek” in you.  I know it is comforting to me to keep this router in my laptop bag.  It, also, makes for great converstation starters with the TSA at the airport.  🙂

Leave a Reply

You must be logged in to post a comment.